z-buffer problem

Zviri

Newcomer
Joined
Aug 16, 2009
Hi
Im making an program using Microsoft Visual c# 2008 EE / directX sdk 2008 (november) the program is working great but on many other computers mostly with integrated graphic cards the program breaks down and it isnt working until I stop using z-buffer which I need....
I tried to create a device : deviceType.Reference instead deviceType.Hardware but it is still the same.

Is there anithing I can do with that? thx

if it is necessary I can upload the whole code / project
 

Zviri

Newcomer
Joined
Aug 16, 2009
update

Ok I can fix it when I use deviceType.Reference but then it is needed to be a directX SDK installed on the computer and thats not very applicable.

thx
 

PlausiblyDamp

Staff member
Joined
Sep 4, 2002
Location
Lancashire, UK
User Rank
*Expert*
Re: update

It could be a driver issue on the target machine - have you tried updating the drivers on one of the failing machines just to see if this fixes the issue?
 

Zviri

Newcomer
Joined
Aug 16, 2009
yes, but no change, Ive tried to use different frameworks 2.0 , 3.0, 3.5 different versions of directX but no use
 

snarfblam

Mega-Ultra Chicken
Staff member
Joined
Jun 10, 2003
Location
USA
User Rank
*Expert*
What happens when the app fails? Are you given an exception? Does it have a DirectX error code?
 

Zviri

Newcomer
Joined
Aug 16, 2009
Ok Ive fixed it.
It was a very trivial mistake I didnt set the BackBufferFormat , with a 16 bit R5G6B5 format it works perfectly
 
Top